Page 1 sur 1

[Résolu] Installation sur un Synology

MessagePublié: 09 Juil 2010, 11:17
par Killy
Trop les boules...

J'ai installé un phpmyadmin sur ce nas.
J'ai suivi le protocole et j'ai clique sur chiffrer le mot de passe....

Je n'ai pas retenu la clef de chiffrement.

Conclusion Plus d'acces à phpmyadmin!!!

Même apres une reinstalle.

Ca fait deja 3 jours que je suis juste à l'essai pour trouver une solution me permettant de voir comment installer Nexev sans pour autant voir ce qu'il y a sous le capot.

avec en plus d'autres probleme a la clef ....

Quelqu'un a t-il une solution pour que je puisse avoir la main a nouveau sur phpmyadmin sur mon syno????

Re: Installation sur un Synology

MessagePublié: 09 Juil 2010, 11:33
par Killy
Une auto reponse:

Bonjour

Dans le manager onglet "restaurer par defaut" restaurer le mdp de mysql

Patrick

C'est vraiment bien fait un synology

Re: Installation sur un Synology

MessagePublié: 09 Juil 2010, 15:35
par Killy
Voila le resultat sur un NAS Synology:

Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/volume1/web/nexev/../../framework/prado/prado.php) is not within the allowed path(s): (/etc:/tmp:/usr/bin/php:/usr/syno/synoman:/var/run:/var/services/blog:/var/services/homes:/var/services/photo:/var/services/web:/var/spool/php:/volume1/@tmp/php:/volume1/homes:/volume1/photo:/volume1/web:) in /volume1/web/nexev/index.php on line 31

Warning: require_once(/volume1/web/nexev/../../framework/prado/prado.php) [function.require-once]: failed to open stream: Operation not permitted in /volume1/web/nexev/index.php on line 31

Fatal error: require_once() [function.require]: Failed opening required '/volume1/web/nexev/../../framework/prado/prado.php' (include_path='.:/usr/syno/php/lib/php') in /volume1/web/nexev/index.php on line 31

Apparement même probleme que sur FREE.

J'ai bien changer le fichier application.xml de la facon suivante:
-----------------------
<parameter id="frameworkRoot" value="../framework/" />
</parameters>
<modules>
<!-- Le module d'accès à  la base -->
<module id="nexev" class="adodb"
Driver="mysql" Host="192.168.0.6/phpMyAdmin/" Username="root" Password="" Database="nexev" />
<!-- Gestion des authentifications -->
------------------------

Les "/../../framework" dans le message d'erreur me plaisent pas car j'ai nien fait les changement dans application?

ensuite je ne sais pas vraiment ou ce trouve ma base de données sur le NAS.
donc à la question HOST=" ??? "

Je pense que ce message d'erreur est récurant quelques soit les bases distantes il vaudrait mieux trouvé la cause (qui doit être bête).
Une fois réglé mettre la solution sur le forum.
Je me laisse encore qq jours pour déployer cette appli apres je baisse les bras.

Car pour l'instant je n'ai pas travailler sur le fond du problème....

Re: Installation sur un Synology

MessagePublié: 09 Juil 2010, 15:53
par Killy
Voici le dernier changement pour aujourd'hui:

dans le fichier appli

<parameter id="frameworkRoot" value="(/volume1/web/framework/" />
</parameters>
<modules>
<!-- Le module d'accès à  la base -->
<module id="nexev" class="adodb"
Driver="mysql" Host="localhost" Username="root" Password="" Database="nexev" />



Même message d'erreur

Sur ce je jette une tete dans ma piscine bye

Re: Installation sur un Synology

MessagePublié: 14 Juil 2010, 11:30
par Killy
OK CA FONCTIONNE: (mettre le post en résolu)

Petit résumé:
Dans le synology:
Dans l'interface du synology avec le compte administrateur (DMS 2.3)
1. activer le serveur web
2. installer le paquet "phpmyadmin" préalablement télécharger sur le site Synology en utilisant la procedure du synology (ce n'est pas seulement un copier coller)
3. Lancer le paquets
4. Mettre les deux dossier "nexev" + "framework" dans le dossier "web"
Rem si vous avez bien installer le paquet phpmyadmin vous voyez aussi un dossier appellé 'phpMyAdmin"

Dans l'interface phpmy admin que vous trouvez par le lien de l'interface du syno ou par l'adresse "http://192.168.0.x/phpMyadmin/
1. Connectez vous avec login "root" mot de passe ne tapez rien
2. Créer une base de données nommée "nexev" garder les paramètres par défaut
Rem attention à ne pas créer une table nexev (ce n'est pas la même chose...)
4. Mettre un mot de passe sur le user "root". Attention ne pas cliquer sur générer sans retenir le mot de passe généré !! (ne faites pas comme moi sinon voir plus haut pour remettre les comptes par défaut!!)
Rem sans mot de passe, l'instal de nexev ne fonctionne pas même si on met les "" dans le fichier application.xml.

Configuration des fichiers de nexev
1. dans le fichier application.xml du dossier protected
---------------------
<parameters>
<parameter id="frameworkRoot" value="../framework/" />
</parameters>
<modules>
<!-- Le module d'accès à  la base -->
<module id="nexev" class="adodb"
Driver="mysql" Host="localhost" Username="root" Password="xxxxxxx" Database="nexev" />
-------------------------


2. dans le fichier inex.php du dossier "nexev" vérifier ceci
------------------------
$frameworkPath=$basePath.'/../framework/prado/prado.php';
------------------------

Travail à faire ensuite pour voir l'application sur internet:
1. sur le routeur (Pour moi la FREEBOX)
Faire une redirection de port (80) vers votre nas.
Je n'ai pas encore vérifier ce que ça donne de l'exterieur de la boucle avec le paramètre localhost...
DOnc a suivre...